Задвоение суммы

Задвоение сумм в запросе

Запрос следующего вида:
Запрос.Текст = «ВЫБРАТЬ РАЗРЕШЕННЫЕ
ЕСТЬNULL(ВТ.СальдоНачальноеДт, 0) КАК СальдоНачальноеДт,
ЕСТЬNULL(ВТ.СальдоНачальноеКт, 0) КАК СальдоНачальноеКт,
ЕСТЬNULL(ХозрасчетныйОб.СуммаОборотДт, 0) КАК ОборотДт,
ЕСТЬNULL(ХозрасчетныйОб.СуммаОборотКт, 0) КАК ОборотКт,
ЕСТЬNULL(ВТ.СальдоКонечноеДт, 0) КАК СальдоКонечноеДт,
ЕСТЬNULL(ВТ.СальдоКонечноеКт, 0) КАК СальдоКонечноеКт,
ХозрасчетныйОб.КорСчет КАК КорСчет,
ЕСТЬNULL(ХозрасчетныйОб.Субконто1, ВТ.Субконто1) КАК Субконто1,
ЕСТЬNULL(ХозрасчетныйОб.Субконто2, ВТ.Субконто2) КАК Субконто2,
ХозрасчетныйОб.Регистратор КАК Разрез
ИЗ
РегистрБухгалтерии.Хозрасчетный.Обороты(&Нач, &Кон, Регистратор, Счет В ИЕРАРХИИ (&ВыбСчет), , Организация = &Организация И Субконто1 = &Значение1) КАК ХозрасчетныйОб
ПРАВОЕ СОЕДИНЕНИЕ
ВремТаб КАК ВТ
ПО
ВТ.Субконто1 = ХозрасчетныйОб.Субконто1 И
ВТ.Субконто2 = ХозрасчетныйОб.Субконто2
ИТОГИ
СУММА(СальдоНачальноеДт),
СУММА(СальдоНачальноеКт),
СУММА(ОборотДт),
СУММА(ОборотКт),
СУММА(СальдоКонечноеДт),
СУММА(СальдоКонечноеКт)
ПО
КорСчет ИЕРАРХИЯ,
Субконто1,
Субконто2,
Разрез
АВТОУПОРЯДОЧИВАНИЕ»;
В запросе идет соединение с временной таблицей другого запроса по остаткам. Далее — процедура, которая выводит данные запроса на печать:
Процедура ВывестиРезультатЗапроса(ИсточникВыборки, Таб, СтрокаАналитика, СтрокаСальдо, СтрокаДО, СтрокаКО, МассивГруппировок, МассивПостфиксов, СтруктураНастроекОтчета, ИндексТекущейГруппировки = 1, РезультатЗапроса = Неопределено, Отступ = «»)
Если РезультатЗапроса = Неопределено Тогда
РезультатЗапроса = ИсточникВыборки;
КонецЕсли;
ТекущаяГруппировка = МассивГруппировок.Получить(ИндексТекущейГруппировки);
ТекущаяГруппировка = ?(ТекущаяГруппировка = «Период» ИЛИ ТекущаяГруппировка = «Регистратор», «Разрез», ТекущаяГруппировка);
ВыборкаРазрезов = ИсточникВыборки.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, ТекущаяГруппировка);
Пока ВыборкаРазрезов.Следующий() Цикл
Если ВыборкаРазрезов = Null Тогда
Продолжить;
КонецЕсли;
Если ИндексТекущейГруппировки = 1 Тогда
Состояние(«Обработано «+Строка(Окр((мТекущееКоличество*100)/ВыборкаРазрезов.Количество(), 0))+» %»);
мТекущееКоличество = мТекущееКоличество+1;
КонецЕсли;
ОбработкаПрерыванияПользователя();
ЗначениеАналитики = ВыборкаРазрезов;
Если ТипЗнч(ВыборкаРазрезов) = Тип(«Дата») Тогда
СтрокаФормата = БухгалтерскиеОтчеты.ПолучитьСтрокуФорматаПериода(Периодичность);
ЗначениеАналитики = Формат(ВыборкаРазрезов, СтрокаФормата);
КонецЕсли;
СтрокаАналитика.Параметры.Аналитика = Отступ+ЗначениеАналитики;
СтрокаАналитика.Параметры.Расшифровка = СтруктураНастроекОтчета;
Таб.Вывести(СтрокаАналитика);
Для Каждого Постфикс Из МассивПостфиксов Цикл
СтрокаСальдо.Параметры.Сумма = ВыборкаРазрезов;
Таб.Присоединить(СтрокаСальдо);
КонецЦикла;
Для Каждого Постфикс Из МассивПостфиксов Цикл
ТекОбласть = ?(Постфикс = «Дт», СтрокаДО, СтрокаКО);
ТекОбласть.Параметры.Сумма = ВыборкаРазрезов;
Таб.Присоединить(ТекОбласть, , , Истина);
ВыборкаКорСчетаРазреза = ВыборкаРазрезов.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, «КорСчет», ТекущаяГруппировка);
ВыборкаКорСчетаОбщая = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, «КорСчет»);
Пока ВыборкаКорСчетаОбщая.Следующий() Цикл
Если ВыборкаКорСчетаОбщая = 0 Тогда
Продолжить;
КонецЕсли;
ВыборкаКорСчетаРазреза.Сбросить();
Если ВыборкаКорСчетаРазреза.НайтиСледующий(ВыборкаКорСчетаОбщая.КорСчет, «КорСчет») Тогда
СуммаОборота = ВыборкаКорСчетаРазреза;
СтруктураНастроекОтчета.КорСчет = ВыборкаКорСчетаРазреза.КорСчет;
Иначе
СуммаОборота = 0;
СтруктураНастроекОтчета.КорСчет = ВыборкаКорСчетаОбщая.КорСчет;
КонецЕсли;
Если Постфикс = «Дт» Тогда
СтруктураНастроекОтчета.СчетДт = ВыбСчет;
СтруктураНастроекОтчета.СчетКт = СтруктураНастроекОтчета.КорСчет;
Иначе
СтруктураНастроекОтчета.СчетДт = СтруктураНастроекОтчета.КорСчет;
СтруктураНастроекОтчета.СчетКт = ВыбСчет;
КонецЕсли;
ТекОбласть.Параметры.Сумма = СуммаОборота;
Таб.Присоединить(ТекОбласть, , , Истина);
КонецЦикла;
ВыборкаКорСчетаОбщая.Сбросить();
КонецЦикла;
Для Каждого Постфикс Из МассивПостфиксов Цикл
СтрокаСальдо.Параметры.Сумма = ВыборкаРазрезов;
Таб.Присоединить(СтрокаСальдо);
КонецЦикла;
СледИндекс = ИндексТекущейГруппировки+1;
Если СледИндекс < МассивГруппировок.Количество() Тогда
ВывестиРезультатЗапроса(ВыборкаРазрезов, Таб, СтрокаАналитика, СтрокаСальдо, СтрокаДО, СтрокаКО, МассивГруппировок, МассивПостфиксов, СтруктураНастроекОтчета, СледИндекс, РезультатЗапроса, Отступ+» «);
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Суть проблемы в том, что при выводе данных в печ. форму происходит задвоение и даже затроение сумм оборотов. При периодичности от декады и больше все нормально. Вопрос: кто-нибудь знает, как избавиться от такой хрени?

Тема: Задвоение НДФЛ в Регистре налогового учета

Быстрый переход Бухучет и Налогообложение Вверх

  • Навигация
  • Кабинет
  • Личные сообщения
  • Подписки
  • Кто на сайте
  • Поиск по форуму
  • Главная страница форума
  • Форум
  • Бухгалтерия
    1. Общая бухгалтерия
      1. Бухучет и Налогообложение
      2. Оплата труда и кадровый учет
      3. Документация и отчетность
      4. Учет ценных бумаг и валютных операций
      5. Внешнеэкономическая деятельность
      6. Внешнеэкономическая деятельность. Таможенный союз
      7. Алкоголь: лицензирование и декларирование
      8. Онлайн-ККТ, БСО, эквайринг и кассовые операции
    2. Отрасли и спецрежимы
      1. Индивидуальные предприниматели. Спецрежимы (ЕНВД, УСН, ПСН, ЕСХН)
      2. Учет в НКО и жилищном хозяйстве
      3. Бухгалтерский учет в строительстве
      4. Бухгалтерский учет в туризме
    3. Бюджетные, автономные и казенные учреждения
      1. Бюджетный учет
      2. Программы для бюджетного учета
    4. Банки
    5. МСФО, GAAP, управленческий учет
  • Юридический отдел
    1. Правовая помощь
    2. Регистрация
    3. Опыт проверок
  • Управление предприятием
    1. Администрирование и управление на предприятии
    2. Аутсорсинг
  • Автоматизация предприятия
    1. Программы для ведения бухгалтерского и налогового учета
      1. Инфо-Бухгалтер
      2. Другие программы
    2. 1C
    3. Электронный документооборот и электронная отчетность
    4. Прочие средства автоматизации труда бухгалтеров
  • Гильдия клерков
    1. Взаимоотношения на работе
    2. Бухгалтерский бизнес
    3. Обучение
    4. Биржа труда
      1. Ищу работу
      2. Предлагаю работу
  • Клуб Клерк.Ру
    1. Пятница
    2. Частные инвестиции
    3. Политика
    4. Спорт. Туризм
    5. Встречи и поздравления
    6. Авторские форумы
      1. Интервью
      2. Простое, как мычание
      3. Авторский форум Goblin_Gaga
        1. Бухгалтера можно…
        2. опусник Гаги
  • Интернет-конференции
    1. Кому я должен — всем прощайте: все о банкротстве физлиц
    2. Архив Интернет-конференций
      1. Интернет-конференции
        1. Обмен электронными документами и сюрпризы от ФНС
        2. Нарушение прав граждан при трудоустройстве и увольнении
        3. Новый порядок сдачи отчетности по НДС в электронном формате
        4. Подготовка годовой финансовой/бухгалтерской отчетности за 2014 год
        5. Все, что вы хотели спросить у оператора обмена электронными документами
        6. Как финансовый кризис превратить в окно возможностей?
        7. НДС: изменения в нормативном регулировании и их реализация в программе «1С:Бухгалтерия 8»
        8. Обеспечение достоверности результатов инвентаризационных мероприятий
        9. Защита персональных данных. Применение ЗПК «1С:Предприятие 8.2z»
        10. Формирование учетной политики компании: возможности сближения с МСФО
        11. Электронный документооборот на службе бухгалтера
        12. Учет времени при различных системах оплаты труда в программе «1С:Зарплата и управление персоналом 8»
        13. Полугодовой отчет по налогу на прибыль: раскроем все секреты
        14. Межличностные отношения на рабочем месте
        15. Облачная бухгалтерия 1С. Стоит ли уходить в облако?
        16. Банковские депозиты: как не потерять и выиграть
        17. Больничные листы и другие пособия за счет ФСС. Порядок расчета и начисления
        18. Клерк.Ру: задайте любой вопрос руководству сайта
        19. Правила расчёта НДС при осуществлении экспортно-импортных операций
        20. Как сдать отчетность в Пенсионный фонд за 3 квартал 2012 года
        21. Отчетность в ФСС за 9 месяцев 2012 года
        22. Подготовка отчетности в ПФР за 2 квартал. Сложные вопросы
        23. Запуск электронных счетов-фактур в России
        24. Как снизить затраты на ИТ-оборудование, ПО и ИТ-персонал с использованием облачных мощностей
        25. Отчетность в ПФР за 1 квартал 2012. Основные изменения
        26. Налог на прибыль: нюансы заполнения декларации за 2011 год
        27. Годовая отчетность в ПФР. Актуальные вопросы
        28. Новое в бухгалтерской отчетности за 2011 год
        29. Отчетность в ФСС в вопросах и ответах
        30. Полугодовая отчетность в ПФР в вопросах и ответах
        31. Расчет пособий по временной нетрудоспособности в 2011 году
        32. Электронные счета-фактуры и электронные первичные документы
        33. Формирование бухгалтерской отчетности за 2010 год
        34. Расчет больничных в 2011 году. Декретные и пособия в переходный период
        35. Новое в законодательстве о налогах и страховых взносах в 2011 году
        36. Изменения в финансовой отчетности в 2011 году
        37. DDoS атаки в России как способ нечестной конкурентной борьбы.
        38. Банковские продукты для физлиц: кредитование, депозиты, спецпредложения
        39. Документ в электронной форме — эффективное решение актуальных проблем
        40. Как найти работу с помощью Клерк.Ру
        41. Предоставление сведений перс. учета за первое полугодие 2010 года
        42. Налоговая ответственность: кто и за что отвечает?
        43. Проверки, взыскание, возврат/зачет налогов и др.вопросы ч.1 НК РФ
        44. Расчет больн. листов и страховых взносов в свете квартальной отчетности
        45. Замена ЕСН страховыми взносами и другие нововведения 2010 года
        46. Ликвидация коммерческих и некоммерческих организаций
        47. Бухгалтерский и налоговый учет товарно-материальных ценностей
        48. Обязательная перерегистрация фирм в соответствии с Законом №312-ФЗ
        49. PR и маркетинг в сфере профессиональных услуг своими силами
        50. Клерк.Ру: смена дизайна
        51. Построение личного финансового плана: мечты и реальность
        52. Подготовка бух. отчетности. Изменения в рос. стандартах учета в 2009 году
        53. Откаты в сфере продаж: за и против
        54. Потеря работы в период кризиса. Что делать?
        55. Все, что вы хотели знать о Клерк.Ру, но стеснялись спросить
        56. Кредит в кризис: условия и возможности
        57. Сохранение капитала во время кризиса: стратегии для частных инвесторов
        58. НДС: вычеты по авансам. Вопросы с ответами и без
        59. Пресс-конференция Деда Мороза
        60. Изменения в Налоговый кодекс, вступающие в силу с 2009 года
        61. Налог на прибыль с учетом последних изменений и разъяснений Минфина
        62. Российский кризис: угрозы и возможности
        63. Сетевой бизнес: качественные товары или развод на деньги?
        64. КАСКО: страховка без секретов
        65. Выплаты физическим лицам
        66. Рейдерство. Как защитить собственный бизнес?
        67. Актуальные вопросы исчисления и возмещения НДС
        68. Спецрежимы: ЕНВД и УСН. Особенности и сложные вопросы
        69. Налог на прибыль. Расчет, особенности исчисления, спорные моменты
        70. Учетная политика для целей бухучета
        71. Налоговые проверки. Практика применения новых правил
        72. НДС: порядок расчета
      2. Аутсорсинг в вопросах и ответах
      3. Как бухгалтеру выполнить требования Закона «О персональных данных»
      4. Идеальный архив бухгалтерских документов
  • Служебные форумы
    1. Архив
      1. FAQ (Часто задаваемые вопросы)
        1. FAQ: Часто задаваемые вопросы по бухучету и налогам
      2. Игры и тренинги
        1. Тренинг по воспитанию самоуверенности
        2. ВЭД в условиях суровой действительности
    2. Книга жалоб и предложений
      1. Дневники